Freitag, 19. Oktober 2018, 04:04 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 26. April 2008, 11:47

Umlaute bei FTP und SMB

Hallo ihr alle!

Es wurde neulich ein Tipp gegeben, wie wir Umlaute über FTP erreichen können. Hierzu geben ich mal meinen Erfahrungsbericht ab, da ich auf mein NAS am meisten per SMB, aber durchaus auch häufig von draußen per FTP zugreife.

Mit einem FTP-Programm wie Filezilla kann ich nun Verzeichnisse mit Umlauten anlegen. Firefox zeigt mit diese Verzeichnisse auch richtig an.
Wenn ich mich mit Windows über den Explorer anmelde und versuche, ein Verzeichnis mit Umlauten zu erstellen, so klappt dies, aber ich kann nicht mehr darauf zugreifen, weil mir nur noch komischer Zeichensalat für dieses Verzeichnis angezeigt wird. Andere Programme haben auch keine Möglichkeit, auf dieses Verzeichnis zuzugreifen.

Die Daten, die sich schon vorher auf der Platte befunden haben und per SMB übertragen wurden, haben in Windows Umlaute, aber nicht über FTP. Umgekehrt trägt nun das Verzeichnis, dass ich mit Filezilla und Umlaut erstellt habe, in Windows in der Netzwerkumgebung einen veränderten Namen.

Also, irgendwie scheinen FTP und SMB verschiedene Zeichensätze zu verwenden. Ich hätte ja nichts dagegen, alle Sachen nochmal per FTP zu übertragen, aber wenn sie dann in meiner Netzwerkumgebung einen falschen Namen haben, dann bringt es nichts. Und als "Die Ärzte"-Fan, ist das ein sehr großes Problem :-)

Kennt ihr dieses Problem auch oder beschränkt ihr euch auf ein Programm und Protokoll?

Viele Grüße vom Rhein!

Eismer

P.S. Danke übrigens an die Gemeinschaft, dass ihr dieses lästige FTP-Upload-Problem gelöst habt!

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Samstag, 26. April 2008, 15:19

RE: Umlaute bei FTP und SMB

Ich habe auch schon bemerkt, dass es da Unterschiede gibt und die Änderung des CharsetRemote=850 noch nicht das Allheilmittel ist. Ob man das hinbekommt – keine Ahnung.

Vielleicht hat ja jemand aus unserer Community Zeit um etwas zu Goggeln und zu Experimentieren.

Bei mir verhält es sich so:

Samba Share und XP Zugriff mit explorer OK
ftp Zugriff mit ftp aus der Dos Box (cmd) OK

ftp mit fireftp NOK
übers Web mit (zB mit www2ftp.de) NOK

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

ultimate

Anfänger

Beiträge: 42

Wohnort: Deutschland/Sachsen

3

Montag, 5. Mai 2008, 21:38

Umlaute richtig dargestellt !!!

Hallo,

ich habe mal ein wenig gegoogelt und probiert. Ich habe jetzt den RemoteCharset auf "iso-8859-1" gestellt und habe damit in den getesteten FTP-Clients (www2ftp, Filezilla, fireftp) gleichbleibend gute Ergebnisse erzielt. Am besten selbst mal testen.
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert, aber niemand weiß warum.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Montag, 5. Mai 2008, 22:29

RE: Umlaute richtig dargestellt !!!

Hallo, danke für die Mühe!

Ich habe das jetzt bei mir noch einmal getestet.
Leider geht bei iso-8859-1 dann das ftp aus der DOS Box nicht. :(

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

ultimate

Anfänger

Beiträge: 42

Wohnort: Deutschland/Sachsen

5

Montag, 5. Mai 2008, 23:42

Hallo,

schade drum, es gibt aber scheinbar keine Universal-Lösung, aber für mich ist die ISO-Variante in Ordnung, da ich normalerweise den DOS-FTP-Clienten nicht nutze.
Ich habe jetzt bestimmt noch eine Stunde rumprobiert mit verschiedenen Codepages, aber ohne Erfolg.

MfG
Ultimate
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert, aber niemand weiß warum.

6

Donnerstag, 8. Mai 2008, 14:05

Hallo!

Ich habe die Einstellung gerade ausprobiert ... ES FUNKTIONIERT!!!!

DANKE!!!

Jetzt ist mein Nas perfekt!

Grüße vom Rhein!

Eismer

7

Freitag, 23. Mai 2008, 23:25

RE: RE: Umlaute bei FTP und SMB

Ich habe auch schon bemerkt, dass es da Unterschiede gibt und die Änderung des CharsetRemote=850 noch nicht das Allheilmittel ist. Ob man das hinbekommt – keine Ahnung.

Vielleicht hat ja jemand aus unserer Community Zeit um etwas zu Goggeln und zu Experimentieren.

Bei mir verhält es sich so:

Samba Share und XP Zugriff mit explorer OK
ftp Zugriff mit ftp aus der Dos Box (cmd) OK

ftp mit fireftp NOK
übers Web mit (zB mit www2ftp.de) NOK

lG HWguru


mit folgenden einstellungen arbeite ich und es läuft:

proftp.conf:

CharsetRemote ISO-8859-1

smb.conf:

unix charset=ISO-8859-1

dos charset=850

display charset=ISO-8859-1

gr flaens
gr flaens