Mittwoch, 20. März 2019, 10:17 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren


Sonntag, 23. Februar 2014, 02:47

Trouble with nfs server openwrt gemini install nas02sg

Im having some troubles with the configuration of the server part. I'm hoping someone may still look here every now and again. I can setup a client on my nas02sg, but cannot see my server from any of my devices in the network. If someone has some input, please help.

Most of what occurs is this
root@blaalala:~# showmount -e "ip address of mzk-nas02sg with openwrt"
clnt_create: RPC: Program not registered

and if I try to connect using a mount off of the blaalala machine, it times out.

Is the NFS server working on the planex build of openwrt? I tried to install a newer version, but the kernel of the openwrt is too old.




Beiträge: 101

Wohnort: Australia


Sonntag, 23. Februar 2014, 13:21

Hi t3ch42,

First I have to point out that this NAS uses a storlink - gemini SOC.
All packages, programs etc have to be cross compiled for the CPU inside that SOC.
There is no point trying to install debian packages designed/compiled for intel or AMD CPU's.

The linux kernel used by this port of OpenWRT is later than any of the OEM firmwares but obviously not up to the latest.
Afterall it is an older NAS and the port was done more than 2 years ago.

The nfs file server works very nicely on this NAS box as that was one of the main reasons why the port was done by the embedded software developer.
I have had nfs working to file share with my windows PC, but now use SMB as it is natively supported by MS windows.
Not much of a linux person myself so can't help much with setting up in that environment.
But I know it does work.


Montag, 24. Februar 2014, 04:49

Hi. Thanks for responding. I was able to figure out the issue with the NFS server. I assumed since it was shown in the web page and it appeared a daemon was running, that it was operating. I did some snooping around in the config directory and found that the server itself was not enabled. Once I changed the 0 to one, started the server, it worked like a champ for about 550 MB of transfer. Then the power dipped during a storm and the entire NAS and some of the network switches and routers stopped communicating. Once i reset the switches, i could talk to most if the devices, but not the nas02sg. Not sure what the problem is yet, but I think the kinks are almost worked out. Hoping it didn't fry, as I was excited to have it running pretty well.



Beiträge: 101

Wohnort: Australia


Montag, 24. Februar 2014, 09:36

Hope you get the NAS box operational again.

Thunderstorms are notorious for frying electronics.
I have a fast switch device on my PC that turns off the supply on any brownout / over-voltage, plus a fair few surge suppressors (varistors) in the supply line to the PC's.
Its not so much the brownout itself (switch mode power supplys are very tolerant) but the surge type transients from line faults, and lightning strikes on the lines, that causes damage.

Does the NAS box power up?

I am pretty sure you can enable the nfs server via the LUCI interface, as I never had to delve into the config files to achieve that.


Montag, 24. Februar 2014, 21:03

Yes, was able to get the device running again. I believe the only device that really took a hit was the Ethernet switch. Its an old device (~13 years maybe?), but it caused a complete upset to my network when it bugged out. Nothing was able to communicate from the main router, but I didn't find this out at first due to my multiple WAP points.
I kept trying to ping the router, but couldn't get through. I pieced it together and realized what had happened, but had almost resolved myself to a serial recovery of the NAS prior to doing so.
As it turns out, all I had to do was restart the switch and NAS and everything was fine!
Time to upgrade some of the equipment I think.



Beiträge: 101

Wohnort: Australia


Donnerstag, 27. Februar 2014, 12:51

That's a lucky outcome, and nice that the NAS box survived.
If you play around with the OpenWRT it would be nice to get some feedback.
Eg, if you make it boot from the HDD instead of the flash memory you have more space to try various packages.


Donnerstag, 27. Februar 2014, 22:10

Well, I have been using it somewhat, but only as a less used storage. NFS speeds were preety good copying from my other devices. I calculated it out but can't recall off hand. Much faster than sshfs.
I have the device set with an overlay from my hard drive with about 500M available on one and 500M from the other if I need it. I couldn't find many programs that weren't installed already though that were in the default repository.
I found those lacking somewhat and used some from the openwrt Gemini port. Some of them worked after adjusting the opkg.conf architecture, but quite a few were not installable due to the older kernel used for this version of openwrt.
I'd like to play around a little more though. Unfortunately, it seems that my home network devices work, but i cant adjust too much. I made a small change to my pogoplug device and I found that i couldn't access it any more. Not a big deal for correcting, but time consuming to fix with removing usb, rebooting, checking and booting again.
I can't seem to leave well enough alone sometimes.



Beiträge: 101

Wohnort: Australia


Samstag, 1. März 2014, 06:29

What is your source for the OpenWRT port?
AFAIK the only OpenWRT port for the gemini SOC, and being specific to this hardware, is the one you find on the opengemini blog.
The peson behind that work also did the OpenWRT port for the MvixBox with some input from me (same hardware - different MTD partitioning).

All of the OPKG packages on the opengemini site were cross compiled from source by the same buildroot that created the OpenWRT firmware.
Surely they do not fail to install because the kernel version is now 'aged'.
More likely other issues are at play like dependancies, hardware limitations, configuration tayloring and even mods to the kernel itself to suit this SOC.

Not being familiar with linux myself I always hoped that others might help with that side of the equation.
Unfortunately, even when I started the user group for this hardware, most people just did the talk the talk instead of the walk the walk.
It's also one of the reasons why I stay interested in this little subforum (graciously provided by the NAS2000 forum owner).

A little while ago a member here was interested in setting up software raid, so I did a buildroot run just to compile MDADM.
It didn't work out of the box and it was abandoned, but I am hoping that one day a user/tinkerer will find out what to do.


Montag, 3. März 2014, 01:05

Hey again. The source that I used for the basic install was from the blog, as default.

What I found was compatible was…emini/packages/
I changed the opkg.conf to allow that architecture and I was able to use a few packages from there that weren't in the other source, screen, Sshfs, a few others. I ran into the kernel problem on one or two packages, but I can't remember off hand.
There is a mdadm ipkg that I just tried and installed without any errors. I am going to attempt to create a software raid with two USB drives I have this evening if I have time.
I have been using Linux for about 13 years as an os and can get my way through most problems through terminal, but I still have a lot of things that I need to research. I have some experience with embedded devices; took the classes in school and quite a bit of playing around with the raspberry pi, wdtv and others. I'd like to know more but now its a matter of having the time to invest in a single project deeper.
Anyhow, I'll let you know how my experience with mdadm works tonight.



Beiträge: 101

Wohnort: Australia


Montag, 3. März 2014, 10:18

Hi t3ch42,

Nice to get someone familiar with Linux, embedded devices and also interested to tinker a bit with this NAS hardware.
I also am still interested, but require incentive to load up and play with Linux and with this NAS.

Those packages from the OpenwWRT site are for the Williboard that uses the same SOC, and are indeed compatible.
I can compile the source for these packages to match the OPKG definitions used by the OpenWRT/OpenGemini port.

What changes did you make to opkg.conf to allow IPKG?
I can provide the mdadm OPKG package as well for comparison.

IIRMC there was a segmentation issue and the setting were not remembered after a reboot with mdadm.


Montag, 3. März 2014, 14:57

The only change I made was to add the architecture entries. These go at the bottom under the other items listed in /etc/opkg.conf

arch all 1
arch noarch 1
arch cs351x 10
arch gemini 100

I tried a full replacement, but after finding a few incompatable packages, I figured it was easier for me to just pick and choose from the repository web directly using opkg install http://*
I didn't get a chance to run my tests. I thought I had cleared out my hard drives but had some data that I wasn't sure I had backed up. I managed to get that cleated up, so I should be able to check it out tonight.
Yes, it is nice to find a niche group for equipment that still has some life in it. I hope that we can find some more use for this device.
I'll start another thread with any other experiences or findings.